summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2015-06-25 00:09:57 -0400
committerDavid Parrish2015-06-25 00:35:11 -0400
commit6646654ab674dfb5e4614ac24491ba3194eeaea0 (patch)
tree2865a7adac442462800f32ce7c065c2e738c0161 /PKGBUILD
downloadaur-6646654ab674dfb5e4614ac24491ba3194eeaea0.tar.gz
Initial commit of go-ethereum
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e625a9b4d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David Parrish <daveparrish@gmail.com>
+
+pkgname=geth-git
+pkgver=v0.9.26.r391.g22c7ce0
+pkgrel=1
+pkgdesc="Ethereum Go Client"
+arch=('i686' 'x86_64')
+url="https://github.com/ethereum/go-ethereum"
+license=('MIT')
+makedepends=('go' 'gmp')
+source=("${pkgname}::git+https://github.com/ethereum/go-ethereum.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgbase"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgbase}"
+ make
+}
+
+package() {
+
+ cd "$pkgbase"
+ install -Dm755 build/bin/geth "$pkgdir"/usr/bin/geth
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}