summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortkit2020-11-10 10:46:51 +0800
committertkit2020-11-10 10:46:51 +0800
commite56bd39af9fb90503310728f3dd1c8d8c4a8f7d2 (patch)
treea40c404ebe7f93e3f5d0392f1d4bfbfab5763a57 /PKGBUILD
downloadaur-e56bd39af9fb90503310728f3dd1c8d8c4a8f7d2.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4679b50f3f94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: HaoCheng <ch1994@outlook.com>
+pkgname=getit
+pkgver=4.0.10
+pkgrel=1
+pkgdesc="Application to send HTTP requests to test your API endpoints."
+arch=('any')
+url="https://github.com/bartkessels/GetIt"
+license=('GPL')
+groups=()
+depends=('webkit2gtk' 'gtksourceview3')
+makedepends=('git' 'gcc' 'meson' 'gettext') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+https://github.com/bartkessels/GetIt.git#tag=${pkgver}")
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname}"
+ meson --prefix=/usr build
+ meson compile -C build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ DESTDIR="$pkgdir" meson install -C build
+
+}