summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Theodorou2015-07-07 22:13:49 +0100
committerAngelo Theodorou2015-07-07 22:13:49 +0100
commit1c96b77e3c172a2e8fd7587275b0e24da3c85da7 (patch)
tree0c4dc32623b0a32c09280d7fdbd812a25f1748b6 /PKGBUILD
downloadaur-getlive.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e5915ec34bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+pkgname=getlive
+_pkgname=GetLive
+pkgver=2.4
+_pkgver=2_4
+pkgrel=1
+pkgdesc="Fetches your Hotmail Live mail"
+arch=('any')
+url="http://sourceforge.net/projects/getlive/"
+license=('GPL')
+depends=('curl' 'perl-uri' 'perl-net-server' 'procmail')
+changelog=getlive.changelog
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/${_pkgname}_${_pkgver}.tgz)
+md5sums=('124e2c5f4a4b1d7b188b6057afb8697e')
+
+package() {
+ cd "$srcdir/${_pkgname}_${_pkgver}"
+
+ mkdir -p $pkgdir/usr/bin/
+ install -m755 {GetLive.pl,SmtpForward.pl,SmtpAuthForward.pl} $pkgdir/usr/bin/
+
+ # Mail Notification expects a "GetLive" command in path
+ cd $pkgdir/usr/bin/
+ ln -s GetLive.pl GetLive
+}