summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriele Musco2019-08-03 11:38:16 +0200
committerGabriele Musco2019-08-03 11:38:16 +0200
commitb28033a99ea1de9bf02136f3db19fede8b0bb2be (patch)
tree12a70615b1b121fc12670ee89ee44626de5733a3 /PKGBUILD
downloadaur-b28033a99ea1de9bf02136f3db19fede8b0bb2be.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16ad37e9d9b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gabriele Musco <emaildigabry@gmail.com>
+# Upstream URL: https://gitlab.com/gabmus/gnome-feeds
+
+pkgname=gnome-feeds-git
+pkgver=0.2.2.r23.g11737b1
+pkgrel=1
+pkgdesc='News reader for GNOME'
+arch=('any')
+url='https://gitlab.com/gabmus/gnome-feeds'
+license=('GPL3')
+depends=('gtk3' 'python' 'python-pillow' 'libhandy' 'python-listparser' 'python-feedparser' 'python-requests' 'python-lxml' 'webkit2gtk' 'python-html5lib' 'python-gobject' 'gobject-introspection')
+makedepends=('git' 'meson')
+provides=('gnome-feeds')
+conflicts=('gnome-feeds')
+source=("gfeeds::git+https://gitlab.com/gabmus/gnome-feeds")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/gfeeds"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/gfeeds"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --buildtype release ..
+ ninja
+}
+
+package() {
+ cd "$srcdir/gfeeds"
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}