summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-10-07 21:20:14 +0300
committerorhun2020-10-07 21:20:14 +0300
commit9dbcfcaec25c784f1af3d120ada3f33eb08390af (patch)
tree479300d3883baa994bf6d9c4efc1f84aa7b7ec82 /PKGBUILD
parent352aeb9eb995ad91c0df82f735ce0dd60680f9f3 (diff)
downloadaur-9dbcfcaec25c784f1af3d120ada3f33eb08390af.tar.gz
upgpkg: gfold-git 0.5.1.r2.g093f3a0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a1ca8663f00..a704d858acfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=gfold-git
-pkgver=0.5.0.r0.gd690fea
+pkgver=0.5.1.r2.g093f3a0
pkgrel=1
pkgdesc="CLI tool to help keep track of Git repositories"
arch=('x86_64')
@@ -10,6 +10,7 @@ url="https://github.com/nickgerace/gfold"
license=('Apache')
makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
source=("git+${url}")
sha512sums=('SKIP')
@@ -20,12 +21,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- cargo build --release
+ cargo build --release --locked --all-features
}
check() {
cd "${pkgname%-git}"
- cargo test --release
+ cargo test --release --locked
}
package() {