summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-08-30 00:08:37 +0300
committerorhun2020-08-30 00:08:37 +0300
commite7c57d79ce91701166b011aa9fe9dded7ce26bdb (patch)
treeac941ff074c7ea708376ee2d8ced09c453a70b71 /PKGBUILD
downloadaur-e7c57d79ce91701166b011aa9fe9dded7ce26bdb.tar.gz
Initial upload: gfold-git 0.3.0.r0.gfa11dd1-1
Add gfold-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0be649101492
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=gfold-git
+pkgver=0.3.0.r0.gfa11dd1
+pkgrel=1
+pkgdesc="CLI tool to help keep track of Git repositories"
+arch=('x86_64')
+url="https://github.com/nickgerace/gfold"
+license=('MIT')
+makedepends=('cargo')
+conflicts=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --release
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+}