summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:15:40 -0400
committerKyle Keen2015-06-13 00:15:40 -0400
commita22634a310cdbd895bfebf849abcbe1783bc7583 (patch)
treee7566ffb4ce8e05e618b9d1b3a7cb13f095c4086 /PKGBUILD
downloadaur-gforth.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b68b4ad12f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Jason Chu <jason@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=gforth
+pkgver=0.7.3
+pkgrel=1
+url="http://www.gnu.org/software/gforth/"
+pkgdesc="Fast and portable implementation of the ANS Forth language"
+arch=('i686' 'x86_64' 'armv6h')
+license=('GPL3')
+depends=('libtool')
+source=("http://www.complang.tuwien.ac.at/forth/$pkgname/$pkgname-$pkgver.tar.gz")
+options=('libtool')
+install=$pkgname.install
+md5sums=('96f2354ec8c4005e1a54035586ed683e')
+md5sums=('ff484391e5cdf405867fcf96341820ab')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ CFLAGS='-std=gnu99' ./configure --prefix=/usr
+ make PREFIX=/usr -j1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+