summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Engestrom2016-11-27 14:10:06 +0000
committerEric Engestrom2016-11-27 14:10:06 +0000
commitebe48d6cf3b237d5b1a7c8b684c17331e9a354af (patch)
treed9cc251e9989c2093b7a2d72ed0a1c0c3c607901 /PKGBUILD
parent82861e2570ae4d83545e3d8f0b70b9b4216e7182 (diff)
downloadaur-ebe48d6cf3b237d5b1a7c8b684c17331e9a354af.tar.gz
use system libs instead of local copies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37a3ed03237d..df38a4404bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=gfxbench
pkgver=4.0.13
-pkgrel=3
+pkgrel=4
pkgdesc="Unified graphics benchmark based on DXBenchmark (DirectX) and GLBenchmark (OpenGL ES)"
url='https://gfxbench.com/'
arch=('i686' 'x86_64')
license=('custom')
-depends=('libpng12')
+depends=('libpng12' 'qt5-base' 'icu')
_basename="gfxbench_gl-linux-qt-${pkgver}+community"
source_i686=( "${_basename}.sh::https://gfxbench.com/download/${_basename}_32bit.sh")
source_x86_64=("${_basename}.sh::https://gfxbench.com/download/${_basename}_64bit.sh")
@@ -30,4 +30,13 @@ package() {
# Fix path
sed -i "s#${pkgdir}##" "${pkgdir}"/opt/"${pkgname}"/gfxbench_gl.desktop
+
+ # Remove unnecessary local copies of libs
+ rm "${pkgdir}"/opt/"${pkgname}"/libQt5*
+ rm "${pkgdir}"/opt/"${pkgname}"/libicu*
+ rm -r "${pkgdir}"/opt/"${pkgname}"/platforms/
+ rm -r "${pkgdir}"/opt/"${pkgname}"/xcbglintegrations/
+
+ # Remove start script, since we're not using the local libs anymore
+ rm "${pkgdir}"/opt/"${pkgname}"/start.sh
}