summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Schiffer2016-01-08 10:33:46 +0100
committerMatthias Schiffer2016-01-08 10:33:46 +0100
commit5214d4a2f54fae94c1a69a389e9973aa251d3dab (patch)
treeea814fa41dcc82c4d85c50180c28fb12b71139d0 /PKGBUILD
parent00b82457a7d3a9a4011ef5cef9059a6bd7345c54 (diff)
downloadaur-5214d4a2f54fae94c1a69a389e9973aa251d3dab.tar.gz
Add -std=c++11 to fix build against new gtkmm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4963456899f2..311f52715ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ggoban
pkgver=0.2
-pkgrel=1
+pkgrel=2
pkgdesc="A gtk go game interface to play and edit game records"
arch=('i686' 'x86_64')
url="https://launchpad.net/ggoban"
@@ -13,6 +13,10 @@ license=('GPL')
build() {
cd "$srcdir/$pkgname-$pkgver"
+
+ # gtkmm doesn't work without C++11 anymore
+ export CXXFLAGS="$CXXFLAGS -std=c++11"
+
./configure --prefix=/usr
make
}