summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVicente Bergas2017-07-19 19:05:11 +0200
committerVicente Bergas2017-07-19 19:05:11 +0200
commit6752cf095ad001ece813270de00a3c7e3316afc4 (patch)
tree3f55183aba52fb9f960ee67d09a22c16061fc1dc /PKGBUILD
parentf9fa14970535adfefbc6b8aa635e0f46e7344425 (diff)
downloadaur-6752cf095ad001ece813270de00a3c7e3316afc4.tar.gz
Update to 2017-03-01 pre-release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD111
1 files changed, 68 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a08c4f726465..d7827c8052f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,27 @@
pkgname=ghdl
-pkgver=0.33
-pkgrel=3
+_tag=2017-03-01
+# The .99 is for pre-release
+pkgver=0.33.99.${_tag//-/.}
+pkgrel=1
+_gccver=6.4.0
+_islver=0.16.1
arch=('i686' 'x86_64')
pkgdesc='VHDL simulator'
-url='http://sourceforge.net/projects/ghdl-updates/'
+url='https://github.com/tgingold/ghdl'
license=('GPLv2')
-
makedepends=('gcc-ada' 'git')
install=ghdl.install
options=(!emptydirs staticlibs)
-_gccver=4.9.3
-_islver=0.12.2
-_cloogver=0.18.1
-
source=(
- "git://github.com/tgingold/ghdl#tag=v${pkgver}"
- "ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_gccver}/gcc-${_gccver}.tar.bz2"
- "ftp://gcc.gnu.org/pub/gcc/infrastructure/isl-${_islver}.tar.bz2"
- "http://www.bastoul.net/cloog/pages/download/cloog-${_cloogver}.tar.gz"
+ "git+https://github.com/tgingold/ghdl#tag=${_tag}"
+ "https://gcc.gnu.org/pub/gcc/releases/gcc-${_gccver}/gcc-${_gccver}.tar.xz"
+ "https://gcc.gnu.org/pub/gcc/infrastructure/isl-${_islver}.tar.bz2"
)
md5sums=(
'SKIP'
- '6f831b4d251872736e8e9cc09746f327'
- 'e039bfcfb6c2ab039b8ee69bf883e824'
- 'e34fca0540d840e5d0f6427e98c92252'
+ '11ba51a0cfb8471927f387c8895fe232'
+ 'ac1f25a0677912952718a51f5bc20f32'
)
prepare() {
@@ -34,9 +31,8 @@ prepare() {
cd "${srcdir}/gcc-${_gccver}"
- # link isl/cloog for in-tree builds
+ # link isl for in-tree build
ln -s ../isl-${_islver} isl
- ln -s ../cloog-${_cloogver} cloog
# Do not run fixincludes
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
@@ -47,7 +43,7 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- mkdir ${srcdir}/gcc-build
+ mkdir "${srcdir}/gcc-build"
}
build() {
@@ -59,40 +55,69 @@ build() {
CXXFLAGS=${CXXFLAGS/-pipe/}
"${srcdir}/gcc-${_gccver}/configure" --prefix=/usr \
- --libdir=/usr/lib --libexecdir=/usr/lib \
- --mandir=/usr/share/man --infodir=/usr/share/info \
- --disable-bootstrap \
- --enable-languages=vhdl \
- --enable-shared --enable-threads=posix \
- --with-system-zlib --enable-__cxa_atexit \
- --disable-libunwind-exceptions --enable-clocale=gnu \
- --disable-libstdcxx-pch --disable-libssp \
- --enable-gnu-unique-object --enable-linker-build-id \
- --enable-cloog-backend=isl \
- --enable-lto --enable-plugin --enable-install-libiberty \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ --enable-threads=posix \
+ --enable-libmpx \
+ --with-system-zlib \
+ --with-isl \
+ --enable-__cxa_atexit \
+ --disable-libunwind-exceptions \
+ --enable-clocale=gnu \
+ --disable-libstdcxx-pch \
+ --disable-libssp \
+ --enable-gnu-unique-object \
+ --enable-linker-build-id \
+ --enable-lto \
+ --enable-plugin \
+ --enable-install-libiberty \
--with-linker-hash-style=gnu \
- --disable-multilib --disable-werror \
- --enable-checking=release
+ --enable-gnu-indirect-function \
+ --disable-multilib \
+ --disable-werror \
+ --enable-checking=release \
+ \
+ --enable-languages=vhdl \
+ --disable-bootstrap \
+ --disable-libgomp \
+ --disable-libquadmath
+
make
+
+ cd "${srcdir}/ghdl"
+ make -j1 \
+ GHDL="${srcdir}/gcc-build/gcc/ghdl" \
+ ANALYZE_OPTS="--GHDL1=${srcdir}/gcc-build/gcc/ghdl1" \
+ STD_GHDL_FLAGS="--GHDL1=${srcdir}/gcc-build/gcc/ghdl1" \
+ vhdl.libs.all libs.vhdl.standard libgrt.a
}
package() {
+ local _xgcc="${srcdir}/gcc-build/gcc/xgcc"
+ local _machine=$(${_xgcc} -dumpmachine)
+ local _version=$(${_xgcc} -dumpversion)
cd "${srcdir}/gcc-build"
# make a full install ...
make DESTDIR="${pkgdir}" install
- # and remove files which are not specific to ghdl
- rm -rf "${pkgdir}/usr/"{share/{locale,gcc-${_gccver},man/man7},include}
- find "${pkgdir}/usr/lib" \
- -maxdepth 1 -mindepth 1 -not -name 'gcc' \
- -exec rm -rf '{}' +
- find "${pkgdir}/usr/lib/gcc/$(./gcc/xgcc -dumpmachine)/${_gccver}" \
- -maxdepth 1 -mindepth 1 -not -name 'vhdl' -not -name 'ghdl1' \
- -exec rm -rf '{}' +
- find "${pkgdir}/usr/bin" \
- "${pkgdir}/usr/share/man/man1" \
- "${pkgdir}/usr/share/info" \
+ # and remove files not specific to ghdl
+ cd "${pkgdir}"
+ rm -rf "usr/"{include,share/{locale,man}}
+ find "usr/lib" \
+ -maxdepth 1 -mindepth 1 -not -name 'gcc' -not -name 'ghdl' \
+ -exec rm -rf {} +
+ find "usr/lib/gcc/${_machine}/${_version}" \
+ -maxdepth 1 -mindepth 1 -not -name 'ghdl*' \
+ -exec rm -rf {} +
+ find "usr/bin" "usr/share/info" \
-maxdepth 1 -mindepth 1 -not -name 'ghdl*' \
- -exec rm -rf '{}' +
+ -exec rm -rf {} +
+
+ # install ghdl-lib
+ cd "${srcdir}/ghdl"
+ make DESTDIR="${pkgdir}" install
}