summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArnaud Dovi2023-02-11 03:08:44 +0100
committerArnaud Dovi2023-02-11 03:08:44 +0100
commitbdf1e53b1a508daa2c3294fc8c0d37a202db09c8 (patch)
tree880645a067baac6f1e3179ddc17a82bd4dee5236 /PKGBUILD
parent9121be14ecdab2697f23ac2a0e74858a5b570c11 (diff)
downloadaur-ghidra-git.tar.gz
add jdk19 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50392309db14..d135260eba5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: nullableVoidPtr <nullableVoidPtr _ gmail _ com>
pkgname=ghidra-git
-pkgver=10.2.2.r620.e5a8f2634
+pkgver=10.2.3.r655.601ab94c1
pkgrel=1
pkgdesc='Software reverse engineering framework (git)'
arch=('x86_64' 'aarch64')
@@ -20,7 +20,7 @@ conflicts=(
)
depends=(
'bash'
- 'java-environment=17'
+ 'java-environment>=17'
'polkit'
)
makedepends=(
@@ -57,8 +57,8 @@ prepare() {
# Check Java version (thanks @ignapk)
JDK_VERSION=$(java -version 2>&1)
- if [[ ! $JDK_VERSION =~ 17\.0 ]]; then
- echo "FAILURE: You seem to have jdk17 installed correctly but your system defaults to another java version. To enable jdk17 please type: sudo archlinux-java set java-17-openjdk"
+ if [[ ! $JDK_VERSION =~ 1[7|9]\.0 ]]; then
+ echo "FAILURE: You seem to have jdk17 or jdk19 installed correctly but your system defaults to another java version. To enable it please type: sudo archlinux-java set java-17-openjdk"
exit 1
fi