summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-04-06 01:51:57 -0400
committerJean Lucas2019-04-06 01:51:57 -0400
commita5c4f0a6d142c237a983e972ccf70e3be19e0284 (patch)
tree05a79e7496c8169e761f1cddf2960cb1721e5a1c /PKGBUILD
parentec4f08d22184edb43d2fcd16c4db18dd0dc72d42 (diff)
downloadaur-a5c4f0a6d142c237a983e972ccf70e3be19e0284.tar.gz
Move repositories inline
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f24a8a9ee27..55279a49b22d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,6 @@ conflicts=(ghidra ghidra-bin)
depends=('java-environment>=11' bash)
makedepends=(gradle unzip)
source=(git+$url
- repositories
https://github.com/pxb1988/dex2jar/releases/download/$_d2j/dex-tools-$_d2j.zip
https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/android4me/AXMLPrinter2.jar
https://sourceforge.net/projects/yajsw/files/yajsw/yajsw-stable-$_yajsw/yajsw-stable-$_yajsw.zip
@@ -23,7 +22,6 @@ noextract=(AXMLPrinter2.jar
yajsw-stable-$_yajsw.zip
hfsexplorer-${_hfsx/./_}-bin.zip)
sha512sums=('SKIP'
- '15a2232450ed6f3dd6b3ce684c0ded9ba156cfa44b9fdbb915350e855b0d8955a976bff992174baace21b5c68b8b0c73072840390d265ad84820319138d65179'
'c4a6c72ea09b58a44fcb8918cfada600467f10f99a02b53d2436ac68295e73c8daf9ba0a8bc7160ba1e28e87f032ee034435ebe40af35b6e2fe9fa4607581358'
'c1168ec913f1fbb0675915d4fd865ec9a8e8573f6c8aedcb6e68166f61f11aeaececc7548d54d78134843c0102c57d6350973f6d3027d0ffdae52a5c57a7f601'
'0ff5a228ae1c5251c8ba59f9bcd9b4a199b0caaf688f6eccba42c3d227784d8f56f9164b2fad73fc173ec314340c036144123ce152fe911013df5598bd708944'
@@ -44,7 +42,16 @@ prepare() {
sed -i '/gradleVersion/,+2d' build.gradle
# Add repositories
- cat ../repositories >> build.gradle
+ cat >> build.gradle << EOF
+
+allprojects {
+ repositories {
+ mavenCentral()
+ jcenter()
+ flatDir name: 'localRepository', dirs: "\${rootDir}/lib"
+ }
+}
+EOF
# Copy libs to common folder
install -Dm 644 ../dex2jar-$_d2j/lib/dex-*.jar \