summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-05-22 00:48:23 -0400
committerJean Lucas2019-05-22 00:48:23 -0400
commite037434fb35deca017fe3615aad42db79ba081c0 (patch)
tree351d27ad33477efd9211ec03bd205cfca6fbf6c3 /PKGBUILD
parentb333b505d3809e8a8f9113a2acfb19e412629ccf (diff)
downloadaur-e037434fb35deca017fe3615aad42db79ba081c0.tar.gz
Remove unneeded variable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c26ff764a81..2cd4f31fec45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,15 +84,12 @@ build() {
gradle buildGhidra
}
-[ "$CARCH" = i686 ] && _platform=linux32
-[ "$CARCH" = x86_64 ] && _platform=linux64
-
package() {
cd ghidra
install -d "$pkgdir"/{opt,usr/bin}
_appver=$(grep -oP '(?<=^application.version=).*$' Ghidra/application.properties)
_relname=$(grep -oP '(?<=^application.release.name=).*$' Ghidra/application.properties)
- unzip -u build/dist/ghidra_${_appver}_${_relname}_$(date +"%Y%m%d")_$_platform.zip -d "$pkgdir"/opt
+ unzip -u build/dist/ghidra_${_appver}_${_relname}_$(date +"%Y%m%d")_linux64.zip -d "$pkgdir"/opt
mv "$pkgdir"/opt/ghidra{_$_appver,}
ln -s /opt/ghidra/ghidraRun "$pkgdir"/usr/bin/ghidra
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/ghidra