summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Claßen2021-03-23 14:25:07 +0100
committerPhilipp Claßen2021-03-23 14:25:07 +0100
commit98247141ed4130199c183af8ce338279c0b14735 (patch)
tree190153e62a0cfc49e2352dd97e4a03a40d383872 /PKGBUILD
parentc23f8916b29315cc984c3b9f7b22e08aa61a4efe (diff)
downloadaur-98247141ed4130199c183af8ce338279c0b14735.tar.gz
- Upgrade to 2021.03.01
- include experimental firejail configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28bebce90957..a4dd67f745f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=ghostery-dawn-bin
_vendorname=ghostery
-pkgver=2021.03
-_builddate=2021-03-11
+pkgver=2021.03.1
+_builddate=2021-03-20
pkgrel=1
pkgdesc="Privacy aware web browser from Ghostery (binary release). Beta release for early access."
arch=('x86_64')
@@ -15,12 +15,15 @@ depends=(dbus-glib
gtk3
libxt
nss)
+optional=('firejail')
install=install
source=("https://github.com/ghostery/user-agent-desktop/releases/download/${_builddate}/Ghostery-${pkgver}.en-US.linux-x86_64.tar.bz2"
- "https://raw.githubusercontent.com/ghostery/user-agent-desktop/master/LICENSE")
-sha256sums=('81b02d93b0f3e3d308dd305a772646ff8b738d1803d8b665e6ee3f3bcd3091ae'
- '1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5')
+ "https://raw.githubusercontent.com/ghostery/user-agent-desktop/master/LICENSE"
+ "ghostery.profile")
+sha256sums=('cb9ca9bf7095ff60cf0d5680e76a2d92ab1bbd48a84f80306e3fe7d30f5e2711'
+ '1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5'
+ 'dbdfb7e32bb874d6b0c67b10524508620e2137662b7f928750f41f0df926040f')
prepare() {
cd $srcdir
@@ -34,6 +37,8 @@ package() {
install -d -m755 ${pkgdir}/usr/lib
cp -R Ghostery ${pkgdir}/usr/lib/${_vendorname}/
+ install -D -m644 ghostery.profile ${pkgdir}/etc/firejail/ghostery.profile
+
install -d -m755 ${pkgdir}/usr/bin
printf '#!/bin/sh
exec /usr/lib/ghostery/Ghostery "$@"' > ${pkgdir}/usr/bin/ghostery