summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotreblan2020-09-30 07:42:38 -0500
committerotreblan2020-09-30 07:42:38 -0500
commit16bc565196f5dfd2c8bb9065067d4f1fa5163ffa (patch)
tree195d3ce76fc7edaf061f44a63f6374253d2f24df /PKGBUILD
downloadaur-16bc565196f5dfd2c8bb9065067d4f1fa5163ffa.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba0a484ebd9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=giara-git
+pkgver=r80.f595496
+pkgrel=1
+epoch=
+pkgdesc="Reddit gtk client"
+arch=('any')
+url="https://gitlab.gnome.org/GabMus/giara"
+license=('GPL3')
+groups=()
+depends=(
+ 'gtksourceview4'
+ 'libhandy1'
+ 'python-dateutil'
+ 'python-flask'
+ 'python-gobject'
+ 'python-mistune'
+ 'python-pillow'
+ 'python-praw'
+ 'webkit2gtk'
+)
+makedepends=('meson' 'git' 'gobject-introspection')
+checkdepends=()
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" redditgtk)
+replaces=("redditgtk")
+source=("$pkgname::git+$url.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/^v-//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+build() {
+ arch-meson "$pkgname" build
+
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}