summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotreblan2020-10-09 15:11:21 -0500
committerotreblan2020-10-09 15:11:21 -0500
commit5eac5565fd6772edabc9da74bc15c8e7b066a925 (patch)
tree46838fc3081cf9b7383a956f33eb8619a304e3dd /PKGBUILD
parent2fa3ada822faa6e24b997d9c9239a45b5fa75fca (diff)
downloadaur-5eac5565fd6772edabc9da74bc15c8e7b066a925.tar.gz
"" and -O pycache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b891c7796d69..42ba0c49acd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=giara-git
pkgver=0.1.r0.g451dd94
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Reddit gtk client"
arch=('any')
@@ -37,7 +37,10 @@ prepare() {
local _ddir="/usr/lib/python$_pver/site-packages/${pkgname%-git}/"
# Generate pycache, if you ran giara as root this will conflict
- python -OO -m compileall . --invalidation-mode checked-hash -d "$_ddir"
+ for f in "" -O;
+ do
+ python $f -m compileall . --invalidation-mode checked-hash -d "$_ddir"
+ done
}
pkgver() {