summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-02-12 16:02:33 +0000
committerDaichi Shinozaki2016-02-12 16:02:33 +0000
commitfd70c7eaf3406a5875a6a2f41b8b1dc2c4072e76 (patch)
treeb6243e679b1c435c2797322ddc209e01736ae7af /PKGBUILD
downloadaur-fd70c7eaf3406a5875a6a2f41b8b1dc2c4072e76.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..369c88a9f651
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+pkgname=gibo
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A shell script for easily accessing gitignore boilerplates"
+url="https://github.com/simonwhitaker/gibo"
+arch=('any')
+license=('custom:UNLICENSE')
+source=("https://github.com/simonwhitaker/$pkgname/archive/$pkgver.tar.gz"
+ "$pkgname.install")
+md5sums=('a6236266d05c949aafc95663fb0e9d98'
+ 'b1b49419e90f7b7f0e84a214ecfdbfef')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ # license
+ install -Dm644 UNLICENSE $pkgdir/usr/share/licenses/$pkgname/UNLICENSE
+
+ # bash
+ mkdir -p $pkgdir/usr/share/bash-completion
+ install -Dm644 ./$pkgname-completion.bash $pkgdir/usr/share/bash-completion/completions/$pkgname
+
+ # zsh
+ mkdir -p $pkgdir/usr/share/zsh/site-functions
+ install -Dm644 ./$pkgname-completion.bash $pkgdir/usr/share/zsh/site-functions/_$pkgname
+}
+