summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgéballin2019-05-15 16:34:00 +0200
committergéballin2019-05-15 16:34:00 +0200
commitefaf17e3f3e174c703d1c38215630c3b8e73de45 (patch)
tree30c9a956b435e4ac1848a7ad74ab665848ab279c /PKGBUILD
downloadaur-gifblock.tar.gz
Initial commit, version 1.0
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..538cd8502077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=gifblock
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Gifblock is a TCL library to Manipulate GIF images streams."
+url="https://github.com/Geballin/Gifblock"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=('tcl')
+optdepends=()
+makedepends=(make gcc)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/Geballin/Gifblock/archive/1.0.tar.gz")
+
+md5sums=(2b3351838b0ac446b0e8fb2222f122da)
+
+build() {
+ cd ${srcdir}/Gifblock-1.0
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/Gifblock-1.0
+ make DESTDIR="${pkgdir}" install
+}