summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 09:28:09 +0200
committerChristian Hesse2015-06-30 09:28:09 +0200
commite32d0b6dbe928f618efe9795b43152fc80672f4f (patch)
tree4f546c82e413b395e78d91d681433f89d9bcbbb6 /PKGBUILD
downloadaur-e32d0b6dbe928f618efe9795b43152fc80672f4f.tar.gz
initial import of giggle-git 0.5.r289.g44490f7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2735bcb15fbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#Maintainer: Christian Hesse <mail@eworm.de>
+#Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
+
+pkgname=giggle-git
+pkgver=0.5.r289.g44490f7
+pkgrel=1
+pkgdesc='A graphical frontend for the git directory tracker - git checkout'
+arch=('i686' 'x86_64')
+url='http://live.gnome.org/giggle'
+license=('GPL')
+depends=('git' 'gtksourceview3' 'vte3')
+options=(!libtool)
+install=giggle.install
+provides=('giggle')
+conflicts=('giggle')
+source=('git://git.gnome.org/giggle')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd giggle/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd giggle/
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd giggle/
+
+ make prefix=${pkgdir}/usr install
+ # this file shouldn't be here
+ rm ${pkgdir}/usr/share/icons/hicolor/icon-theme.cache
+}
+