summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsu2262022-09-11 09:56:06 +0800
committersu2262022-09-11 09:56:06 +0800
commit5167ce8d103f82a63a7e9ca0bd046e2473fdfb7c (patch)
tree376b4f9cca34015cd0deb816bb9558e1c6442199 /PKGBUILD
parenta8f58a4cccd6d1a8a9a54a47ac191e954fc710a7 (diff)
downloadaur-5167ce8d103f82a63a7e9ca0bd046e2473fdfb7c.tar.gz
fix builing with libheif 1.13.0+
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ba4bff8d4df..ad14da2132d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,11 +35,17 @@ optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cu
'lua51-lgi: LUA scripting support')
provides=("${_pkgname}=${pkgver}")
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz
- linux.gpl)
+ linux.gpl
+ file-heif.diff)
sha256sums=('7ba1b032ea520d540e4acad3da16d8637fe693743fdb36e0121775eea569f6a3'
- '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+ '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3'
+ '4996eedcf6d8238c21c52c70ac4b3027f007b2a2a8f1eab9a0caaee6989dcc35')
build() {
- arch-meson "${_pkgname}-${pkgver}" build \
+ local _dir="${_pkgname}-${pkgver}"
+ # fix builing with libheif 1.13.0+
+ # see https://gitlab.gnome.org/GNOME/gimp/-/issues/8570
+ patch "$_dir/plug-ins/common/file-heif.c" < file-heif.diff
+ arch-meson "$_dir" build \
-Dgi-docgen=enabled \
-Dg-ir-doc=true
meson compile -C build