summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsu2262024-02-28 20:37:49 +0800
committersu2262024-02-28 20:37:49 +0800
commitbc77f99d2c044a803cd739cd77e52a96a4ecf35f (patch)
tree64ca81981995ed2dfe5b6d619c7850000586f310 /PKGBUILD
parent4bb7684249db98e71cf8c7c3421ed58a96b5696b (diff)
downloadaur-bc77f99d2c044a803cd739cd77e52a96a4ecf35f.tar.gz
Clean up depends and makedepends according to INSTALL.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 30 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16110380bedb..b9937a1783cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,37 @@
_pkgname=gimp
pkgname=${_pkgname}-devel-noconflict
pkgver=2.99.18
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Image Manipulation Program (Development version, doesn't conflict with gimp 2.0)"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.gimp.org/"
license=('GPL' 'LGPL')
-depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
- 'libexif' 'libgudev' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1' 'cfitsio'
- 'babl>=0.1.98' 'gegl>=0.4.48' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
-makedepends=('appstream' 'intltool' 'libxslt' 'glib-networking'
- 'alsa-lib' 'curl' 'ghostscript' 'libxpm'
- 'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl' 'qoi-headers'
- 'gjs' 'luajit' 'meson' 'gobject-introspection'
- 'gi-docgen' 'xorg-server-xvfb' 'vala' 'highway') # 'yelp-tools')
-checkdepends=('xorg-server-xvfb')
-optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
- 'alsa-lib: for MIDI event controller module'
- 'curl: for URI support'
- 'ghostscript: for postscript support'
- 'libxpm: XPM support'
+depends=(appstream-glib atk 'babl>=0.1.98' cairo fontconfig freetype2 gdk-pixbuf2 'gegl>=0.4.48' libgexiv2 glib2 glib-networking gtk3 gvfs harfbuzz bzip2 libjpeg xz libmypaint libpng poppler-glib librsvg libtiff lcms2 mypaint-brushes1 pango poppler-data zlib libxmu)
+makedepends=(cfitsio ghostscript aalib libheif libmng libwebp libwmf libxcursor libxpm openexr openjpeg2 libjxl qoi-headers vala meson gobject-introspection alsa-lib gjs appstream)
+# 'gutenprint: for sophisticated printing only as gimp has built-in cups print support' # GIMP 2.0 only
+optdepends=('alsa-lib: for MIDI event controller module'
+ 'cfitsio: FITS format support'
+ 'ghostscript: PostScript support'
+ 'aalib: ASCII art support'
'libheif: HEIF support'
- 'libjxl: JPEG XL support'
- 'libwebp: WebP support'
'libmng: MNG support'
- 'iso-codes: Language support'
- 'aalib: ASCII art support'
- 'zlib: Compression routines'
- 'gjs: JavaScript scripting support'
- 'luajit: LUA scripting support'
- 'lua51-lgi: LUA scripting support')
+ 'libwebp: WebP support'
+ 'libwmf: WMF support'
+ 'libxcursor: X11 cursor support'
+ 'libxpm: X11 pixmap support'
+ 'openexr: OpenEXR support'
+ 'openjpeg2: JPEG 2000 support'
+ 'libjxl: JPEG XL support'
+ 'darktable: Importing RAWs'
+ 'rawtherapee: Importing RAWs'
+ 'gdb: Debugger'
+ 'lldb: Debugger'
+ 'graphviz: "Show Image Graph" in "File > Debug" menu' # devel only
+ 'xdg-utils: Sending email with xdg-email'
+ 'luajit: Lua scripting support'
+ 'lua51-lgi: Lua scripting support'
+ 'python-gobject: Python scripting support'
+ 'gjs: JavaScript scripting support')
provides=("${_pkgname}=${pkgver}")
source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${_pkgname}-${pkgver}.tar.xz
linux.gpl)
@@ -41,9 +43,11 @@ sha256sums=('8c1bb7a94ac0d4d0cde4d701d8b356387c2ecd87abbd35bbf7d222d40f6ddb6e'
build() {
local meson_options=(
- # -Dgi-docgen=enabled
- # -Dg-ir-doc=true
- -Dilbm=disabled
+ -Dgi-docgen=disabled # enabled by default, depends on gi-docgen
+ # -Dg-ir-doc=false # disabled by default, depends on yelp-tools
+ -Dheadless-tests=disabled # enabled by default, depends on xorg-server-xvfb
+ # -Dwebkit-unmaintained=true # disabled by default, depends on webkit2gtk (4.0)
+ -Dilbm=disabled # no libilbm in official repo or aur
)
arch-meson "${_pkgname}-${pkgver}" build "${meson_options[@]}"