summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorElMastro2015-12-15 00:49:40 +0100
committerElMastro2015-12-15 00:49:40 +0100
commit2360d7b646f831caac1fe274f854eb2f5434b345 (patch)
treef1e04e97b8f6fd9c19b7f319f3538bd1baab5ec6 /PKGBUILD
parentdc6f5b6dc2784f83092fb925f088b6ce632b2781 (diff)
downloadaur-2360d7b646f831caac1fe274f854eb2f5434b345.tar.gz
Optional Dependencies works, but x264. Added CFLAGS for compilation
problems.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f967432fdaa..613da1c3ac39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
#Maintainer: M. Mastroeni <the_maxtro@hotmail.it>
pkgname=gimp-gap
pkgver=2.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="Gimp Animation Package, gimp's plugin for animation"
url="https://www.gimp.org/tutorials/Using_GAP/"
arch=('x86_64' 'i686')
license=('GPLv3')
depends=('gimp>=2.6.0' 'glib2')
-optdepends=('libxvid: compression codec'
+optdepends=('xvidcore: compression codec'
'libbz2: data compressor'
'faac: audio encoder'
- 'faad: audio decoder'
- 'libmp3lame: mpeg layer 3 codec'
+ 'faad2: audio decoder'
+ 'lame: mpeg layer 3 codec'
'libx264: H264 codec')
source=("http://download.gimp.org/pub/gimp/plug-ins/v2.6/gap/${pkgname}-${pkgver}.tar.bz2")
md5sums=('249ed829de8b78675c0fe4ef4212089f')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure CC="gcc" CXX="g++" LDFLAGS=-lm
+ ./configure CC="gcc" CXX="g++" LDFLAGS="-lm" CFLAGS="-g"
cmake
make
}