summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGarrett Wilson2015-08-10 19:21:35 -0500
committerGarrett Wilson2015-08-10 19:21:35 -0500
commitd1e2588f1a2b4407d7fa4ab6efa6e6348cda23bd (patch)
tree906175caf888527300ac1f5e2f7ad3d90b75339b /PKGBUILD
downloadaur-gimp-plugin-insanebump.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..883375fd1452
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Garrett <floft.net/contact>
+pkgname=gimp-plugin-insanebump
+pkgver=3
+pkgrel=1
+pkgdesc="A GIMP plugin for bump maps"
+arch=('any')
+url='http://registry.gimp.org/node/28117'
+license=('GPLv3')
+depends=('gimp' 'python2')
+source=('http://registry.gimp.org/files/InsaneBump.py_3.txt')
+md5sums=('48a85ef45387b621303ac72fb67be3fe')
+
+build() {
+ sed -i "s/env python/&2/" "$srcdir/InsaneBump"*
+}
+
+package() {
+ dir="$pkgdir/usr/lib/gimp/2.0/plug-ins/"
+ mkdir -p "$dir"
+ cp "$srcdir/InsaneBump"* "$dir/InsaneBump.py"
+ chmod +x "$dir/InsaneBump.py"
+}