summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Schaffrath2019-06-05 04:02:35 +0200
committerPhilipp Schaffrath2019-06-05 04:02:35 +0200
commitc20fd569a662cabdcba1d1ea4b30abd18f4b84d0 (patch)
tree168da1568bfd7aae2d16442afee3bd5747b2843e /PKGBUILD
parentfa94e755a4e6130f343d70c21ab5c6a35c9fd780 (diff)
downloadaur-c20fd569a662cabdcba1d1ea4b30abd18f4b84d0.tar.gz
1.0 release, hard dependency on xdotool, new optional dependency on libnotify, removed zenity dependency, updated pkgver function to work with un-annotated tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb10e8f05ca4..2521b074ff24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Philipp Schaffrath <aur at philipp dot schaffrath dot email>
pkgname=giph-git
-pkgver=r47.8e52600
+pkgver=v1.0.r0.gd7eccda
pkgrel=1
pkgdesc='gif recorder that records the desktop, a window or a selection'
url='https://github.com/phisch/giph'
license=('MIT')
arch=('any')
-depends=('bash' 'ffmpeg')
+depends=('bash' 'ffmpeg' 'xdotool')
optdepends=('slop: for interactive selection'
- 'xdotool: for window or desktop recording'
- 'zenity: for a graphical user interface')
+ 'libnotify: for error and success notifications')
makedepends=('git')
provides=('giph')
conflicts=('giph')
@@ -20,7 +19,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}