summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-09 19:54:51 +0300
committerIgor Dyatlov2021-08-09 19:54:51 +0300
commite7cee9eb1eb0fda4101cf835202f6fac0968e8e3 (patch)
tree137bd97f50f7efb7218ef39dddd3fa997fcba9b2 /PKGBUILD
downloadaur-e7cee9eb1eb0fda4101cf835202f6fac0968e8e3.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96327f0660d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=girens
+pkgver=1.1.9
+pkgrel=1
+pkgdesc="Girens is a Plex GTK client for playing movies, TV shows and music from your Plex library"
+arch=('any')
+url="https://gitlab.gnome.org/tijder/girens"
+license=('GPL3')
+depends=('mpv' 'plex-remote' 'python-plexapi' 'libass' 'libhandy' 'fribidi' 'ffmpeg' 'python-mpv' 'python-idna' 'python-certifi' 'python-chardet' 'python-urllib3' 'python-requests' 'python-tqdm' 'python-six' 'python-websocket-client')
+makedepends=('meson')
+source=("https://gitlab.gnome.org/tijder/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('SKIP') #autofill using updpkgsums
+
+build() {
+ arch-meson "$pkgname-v$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+} \ No newline at end of file