summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoradrien10182023-06-16 19:15:57 +0800
committeradrien10182023-06-16 19:15:57 +0800
commit59f58751cded039253eb0663bb9f3a5d8752392b (patch)
treeab6873b8f0a6def3cbcfd20131f8d5d414cdcb3c /PKGBUILD
parentbf321375e9dbe8cae467aad54a97a8662f3246e6 (diff)
downloadaur-gis-weather.tar.gz
Update to 0.8.4.17
Using the PKGBUILD of gis-weather-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d43d8d8360e..e76ffc3574ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,43 @@
# Maintainer: Haron Prime (Haron_Prime) <haron.prime@gmx.com>
pkgname=gis-weather
-pkgver=0.8.4.1
+pkgver=0.8.4.17
pkgrel=1
pkgdesc="Customizable weather widget"
-arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/gis-weather"
-license=('GPLv3')
+arch=('any')
+url="https://github.com/RingOV/gis-weather"
+license=('GPL3')
groups=()
-depends=('gtk3' 'python' 'python-gobject' 'python-cairo')
+depends=('gtk3' 'libappindicator-gtk3' 'python' 'python-cairo' 'python-distro' 'python-gobject')
optdepends=('librsvg')
provides=()
conflicts=('gis-weather-git')
-source=(${url}/files/${pkgname}/${pkgver}/${pkgname}_${pkgver}_all.deb/download)
-sha256sums=('5e2856f8201942959d790a9ebe8e790e71d71554c6984c990254088e23693fe3')
+source=(
+ "https://github.com/RingOV/${pkgname}/archive/refs/tags/v${pkgver}.zip"
+ "gis-weather.desktop"
+)
+sha256sums=(
+ 'a50f5604a3ca4ee90181c96adafdfc40e95a8ae542afde8bfb709aeef89134d2'
+ 'e5bd1f85c730fcf4a5cc2618b2cb3184597443188b12eb2071540468418575e3'
+)
package() {
- cd "$srcdir"
- tar -xf data.tar.xz -C "${pkgdir}"
- echo "aur" > "${pkgdir}/usr/share/${pkgname}/package"
- chmod -R 777 "${pkgdir}"/usr/share/${pkgname}
- mkdir -p $pkgdir/usr/bin
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # symlink executable
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s '/usr/share/gis-weather/gis-weather.py' "$pkgdir/usr/bin/gis-weather"
+
+ # install files
+ install -vDm0755 'gis-weather.py' -t "$pkgdir/usr/share/gis-weather"
+ install -vDm0644 'icon.png' -t "$pkgdir/usr/share/pixmaps"
+ install -vDm0644 "$srcdir/gis-weather.desktop" -t "$pkgdir/usr/share/applications"
+
+ install -vDm0644 {'icon.png','README.md'} -t "$pkgdir/usr/share/gis-weather"
+
+ #install folders
+ for _f in 'dialogs' 'i18n' 'po' 'services' 'themes' 'utils' ; do
+ cp --reflink=auto -r "$_f" "$pkgdir/usr/share/gis-weather/"
+ done
}