summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHaron-Prime2015-10-18 17:15:19 +0300
committerHaron-Prime2015-10-18 17:15:19 +0300
commit985d5b0542be052bd36a01e0d6598cc80dabb1ca (patch)
tree0ae1aec68dbdbd83f344f5408405daefb357865f /PKGBUILD
downloadaur-985d5b0542be052bd36a01e0d6598cc80dabb1ca.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4aa592d5283
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+
+# Maintainer: Haron Prime (Haron_Prime) <haron.prime@gmx.com>
+pkgname=gis-weather-git
+pkgver=0.7.8.13
+pkgrel=1
+pkgdesc="Customizable weather widget"
+arch=('i686' 'x86_64')
+url="https://github.com/RingOV/gis-weather"
+license=('GPLv3')
+groups=()
+depends=('gtk3' 'python' 'python-gobject' 'python-cairo')
+makedepends=('git')
+provides=()
+conflicts=('gis-weather')
+
+source=("${pkgname}::git://github.com/RingOV/gis-weather")
+md5sums=('SKIP')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/gis-weather
+ mkdir -p ${pkgdir}/usr/share/applications
+ cp -R $srcdir/$pkgname/. $pkgdir/usr/share/gis-weather
+ rm -fr $pkgdir/usr/share/gis-weather/.git
+ chmod -R 777 $pkgdir/usr/share/gis-weather
+ echo "exec python3 /usr/share/gis-weather/gis-weather.py $*" > ${pkgdir}/usr/bin/gis-weather
+ chmod 755 ${pkgdir}/usr/bin/gis-weather
+ echo "[Desktop Entry]
+Name=Gis Weather
+Comment=Weather widget
+Categories=GNOME;Utility;
+Exec=/usr/bin/gis-weather
+Icon=/usr/share/gis-weather/icon.png
+Terminal=false
+Type=Application" > $pkgdir/usr/share/applications/gis-weather.desktop
+ #install -Dm644 "gis-weather.desktop" "$pkgdir/usr/share/applications/gis-weather.desktop"
+ #install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}