summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorybnd2020-04-20 13:27:52 +0200
committerybnd2020-04-20 13:27:52 +0200
commit60ee0ab1764ee37faac59934ffeefd61a4a574f2 (patch)
tree3d7bc2beae02238dcabb01b64868fa10eb0a0e08 /PKGBUILD
downloadaur-60ee0ab1764ee37faac59934ffeefd61a4a574f2.tar.gz
Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..548cbf641904
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Yury Bondarenko < ybnd at tuta dot io >
+
+pkgname=git-annex-adapter
+pkgver=0.2.1
+pkgrel=0
+pkgdesc='Call git-annex commands from Python'
+url='https://github.com/alpernebbi/git-annex-adapter'
+license=('GPL3')
+arch=('any')
+depends=('git-annex' 'python-pygit2')
+makedepends=('python-setuptools')
+source=("https://github.com/alpernebbi/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('218736e8eee4b9200a4a76aae7e0f0c98feb1e91ca6dcf0132c83e8c2614bd3b')
+
+
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python setup.py install --optimize=1 "--root=${pkgdir}"
+}