summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Nixon2016-04-29 12:03:17 +0100
committerChris Nixon2016-04-29 12:03:17 +0100
commit4176bdbde717446b973ac5060a44a942f17cdb11 (patch)
tree186e19e3f60a0dee74c05c809c70c77cc6839c24 /PKGBUILD
parent1326e19ad7a7f952ca784e97e0929ea05dc4f8d6 (diff)
downloadaur-git-annex-stack.tar.gz
Tidied
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2c25bd29894..fe4fc08d4435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,15 +69,6 @@ pkgver(){
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd git-annex
- msg2 "Features: ${_features[*]}"
- stack init --force --system-ghc
- stack setup
- mkdir -p "bin"
- stack install --local-bin-path "bin" $_stack_flags
-}
-
# This involves a recompile, uncomment if you're patient.
# check() {
# cd git-annex
@@ -85,6 +76,10 @@ build() {
# }
package() {
+ cd git-annex
+ msg2 "Features: ${_features[*]}"
+ stack init --force --system-ghc
+ stack setup
mkdir -p "$pkgdir/usr/bin"
- cp git-annex/bin/* "$pkgdir/usr/bin"
+ stack install --local-bin-path "$pkgdir/usr/bin" $_stack_flags
}