summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:44:22 -0600
committerBrian Bidulock2015-06-10 05:44:22 -0600
commit10ce0b845472a8414bbd86bd868ce0496e24c66b (patch)
tree7d89964d836b281a370b83a9eb0e0e2bd91eee22 /PKGBUILD
downloadaur-10ce0b845472a8414bbd86bd868ce0496e24c66b.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a5262ee66f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=git-bzr-kfish-git
+pkgver=1.1.r62.gf798106
+pkgrel=1
+epoch=1
+pkgdesc="a bidirectional git - bazaar gateway"
+arch=('any')
+url="https://github.com/kfish/git-bzr"
+license=('GPL')
+depends=('git' 'bzr' 'bzr-fastimport')
+source=("$pkgname::git+https://github.com/kfish/git-bzr.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags|sed -r 's,^[a-zA-Z]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ mkdir -p "${pkgdir}/usr/bin/"
+ install git-bzr "${pkgdir}/usr/bin/"
+}