summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2014-08-28 22:29:53 -0600
committerBrian Bidulock2015-06-10 05:44:23 -0600
commite24cc18aa508159f56172f8cadec57c9415d6654 (patch)
treee103d020c302c2a6116dcf6db6800b7c4b234bbe /PKGBUILD
parent9d99f58124caf7bb0f232cf919bcf496c8417e05 (diff)
downloadaur-e24cc18aa508159f56172f8cadec57c9415d6654.tar.gz
version 1.1.r62.gf798106-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b9fd29f8958..c8f9c5b5bf2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
-# Maintainer: Mitchel Humpherys <mitch.special@gmail.com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=git-bzr-kfish-git
-pkgver=20120319
+pkgver=1.1.r62.gf798106
pkgrel=1
+pkgepoch=1
pkgdesc="a bidirectional git - bazaar gateway"
arch=('any')
url="https://github.com/kfish/git-bzr"
license=('GPL')
depends=('git' 'bzr' 'bzr-fastimport')
-source=()
-md5sums=()
-
-_gitroot='https://github.com/kfish/git-bzr.git'
-_gitname='git-bzr'
-
-build() {
- cd "$srcdir"
- msg "Connecting to git server..."
- if [[ -d $_gitname ]]; then
- cd $_gitname && git pull origin
- msg "The local files are up-to-date"
- else
- git clone $_gitroot $_gitname --depth=1
- cd $_gitname
- fi
+source=("$pkgname::git+https://github.com/kfish/git-bzr.git")
+md5sums=('SKIP')
+pkgver() {
+ cd $pkgname
+ git describe --long --tags|sed -r 's,^[a-zA-Z]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
}
package() {
- cd "$srcdir/$_gitname"
+ cd $pkgname
mkdir -p "${pkgdir}/usr/bin/"
install git-bzr "${pkgdir}/usr/bin/"
}