summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-11-10 17:17:51 -0700
committerMark Wagie2022-11-10 17:17:51 -0700
commit054b8d57dca5e1d4043bdb74ebf3a9b0ff3bbcd9 (patch)
tree2105f1ef0b379807ad045017d4400a6f38345046 /PKGBUILD
parente1320c25f3c9e2bf88ebbf397960f4a8ece5833b (diff)
downloadaur-054b8d57dca5e1d4043bdb74ebf3a9b0ff3bbcd9.tar.gz
4.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 905f6b690d92..d33213ba6a77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
-pkgver=4.0.2
-pkgrel=4
+pkgver=4.0.3
+pkgrel=1
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
url="https://git-cola.github.io"
@@ -16,20 +16,11 @@ checkdepends=('appstream-glib' 'desktop-file-utils')
optdepends=('python-pygments: syntax highlighting'
'python-send2trash: enables "Send to Trash" functionality.'
'tcl: to use the built-in ssh-askpass handler')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
- 'https://github.com/git-cola/git-cola/commit/8f0f22e2adc7dfb09a75879fab9bb5404d33d561.patch')
-sha256sums=('b5692841002895bfb2a42be5c8352dbeb454b26f267f56e15d9888e57de0a1b4'
- 'SKIP'
- 'a0599494f83316bcdd5af2fd7620f10079248a0a061a009e7456579732ee46ce')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+sha256sums=('bb9c7d5e9149eca61ac2b485ea38b881937d6d6eef3425e9c64a2590f8272348'
+ 'SKIP')
validpgpkeys=('FA41BF59C1B48E8C5F3DA61C8CE26BF4A9F606B0') # David Aguilar <davvid@gmail.com>
-prepare() {
- cd "$pkgname-$pkgver"
-
- # https://github.com/git-cola/git-cola/issues/1263
- patch -Np1 -i ../8f0f22e2adc7dfb09a75879fab9bb5404d33d561.patch
-}
-
build() {
cd "$pkgname-$pkgver"
python -m build --wheel --no-isolation