summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-05-15 09:27:30 -0600
committerMark Wagie2023-05-15 09:27:30 -0600
commit3a82a8b6d40987c35ef5309f2014de2e05e4c804 (patch)
tree08f7c87106406f6019787b1b36a1aa9dbee155ae /PKGBUILD
parent09dc5ac766aa6f163b422136ded036b1e994fac0 (diff)
downloadaur-3a82a8b6d40987c35ef5309f2014de2e05e4c804.tar.gz
remove vendorized polib.py & drop tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 409eac30fb6d..74ec3ce4fb0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,35 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
pkgver=4.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
url="https://git-cola.github.io"
license=('GPL2')
-depends=('git' 'hicolor-icon-theme' 'python-numpy' 'python-pyqt5' 'python-qtpy')
+depends=('git' 'hicolor-icon-theme' 'python-numpy' 'python-polib' 'python-pyqt5'
+ 'python-qtpy')
makedepends=('python-build' 'python-installer' 'python-jaraco.packaging'
- 'python-rst.linker' 'python-setuptools-scm' 'python-sphinx' 'python-wheel')
-checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-flake8')
+ 'python-rst.linker' 'python-setuptools-scm' 'python-sphinx'
+ 'python-wheel')
+checkdepends=('appstream-glib' 'desktop-file-utils')
optdepends=('python-pygments: syntax highlighting'
'python-send2trash: enables "Send to Trash" functionality.'
'tcl: to use the built-in ssh-askpass handler')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
+ '0001-Unvendorize-polib.py.patch')
sha256sums=('187fa9003d74a8fb3d110207b37c6bbe44043dafda06ce111e1922d0f0f06213'
- 'SKIP')
+ 'SKIP'
+ '00db8356a4bc6f1d9dade64ab04b6f8bada2df22b246e21551ce925de9f95625')
validpgpkeys=('FA41BF59C1B48E8C5F3DA61C8CE26BF4A9F606B0') # David Aguilar <davvid@gmail.com>
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Remove vendorized polib.py
+ patch -Np1 -i ../0001-Unvendorize-polib.py.patch
+ rm cola/polib.py
+}
+
build() {
cd "$pkgname-$pkgver"
python -m build --wheel --no-isolation
@@ -29,11 +41,6 @@ build() {
check() {
cd "$pkgname-$pkgver"
-
- # Run the unit tests
- GIT_CONFIG_NOSYSTEM=true LC_ALL="C.utf8" \
- make test
-
desktop-file-validate share/applications/*.desktop
appstream-util validate-relax --nonet share/metainfo/*.appdata.xml
}