summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-08-13 08:17:09 -0600
committerMark Wagie2023-08-13 08:17:09 -0600
commit80aac04d50969fe9352bb189073a3bd9b2bfd02a (patch)
tree725d0e33d1d234506c602dbae1ce9166b836420b /PKGBUILD
parent38eb890e0be6b292384dfefb556c9e621063f06d (diff)
downloadaur-80aac04d50969fe9352bb189073a3bd9b2bfd02a.tar.gz
4.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a66b5c88f32d..f77ce7af8fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Paul Weingardt <paulweingardt@web.de>
-# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
-pkgver=4.2.1
-pkgrel=3
+pkgver=4.3.0
+pkgrel=1
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
url="https://git-cola.github.io"
license=('GPL2')
-depends=('git' 'hicolor-icon-theme' 'python-numpy' 'python-polib' 'python-pyqt5'
- 'python-qtpy')
+depends=('git' 'hicolor-icon-theme' 'python-importlib-metadata' 'python-numpy'
+ 'python-polib' 'python-pyqt5' 'python-qtpy')
makedepends=('python-build' 'python-installer' 'python-jaraco.packaging'
'python-rst.linker' 'python-setuptools-scm' 'python-sphinx'
'python-wheel')
@@ -19,7 +19,7 @@ optdepends=('python-pygments: syntax highlighting'
'tcl: to use the built-in ssh-askpass handler')
source=("$pkgname-$pkgver.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz"
'0001-Unvendorize-polib.py.patch')
-sha256sums=('400fed3bac785f7d6c513b19d6a795953367029510ac5dc8b4320864d75cbbac'
+sha256sums=('00171351fd0441b5e3fcd2bb4b488d671cf7f05c23aecb8e5579030cfd282989'
'00db8356a4bc6f1d9dade64ab04b6f8bada2df22b246e21551ce925de9f95625')
prepare() {
@@ -48,4 +48,8 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
make prefix=/usr DESTDIR="$pkgdir" install-man
+
+ install -Dm644 "contrib/_${pkgname}" -t "$pkgdir/usr/share/zsh/site-functions/"
+ install -Dm644 "contrib/$pkgname-completion.bash" \
+ "$pkgdir/usr/share/bash-completion/completions/$pkgname"
}