summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcin Wieczorek2021-01-18 20:04:39 +0100
committerMarcin Wieczorek2021-01-18 20:04:39 +0100
commitb5aa449e4741fa36e66d4f19f4d9b6316ab35f26 (patch)
tree372657bfc3977b59426f7f756283f8d24896104d /PKGBUILD
parentf65d845cdd2c186866fcdbe08e21a6cc4a607c77 (diff)
downloadaur-b5aa449e4741fa36e66d4f19f4d9b6316ab35f26.tar.gz
Version 3.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0653fcae6750..39e2007a61ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Paul Weingardt <paulweingardt@web.de>
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
-pkgver=3.7
+pkgver=3.8
pkgrel=1
pkgdesc="A powerful GUI for Git"
arch=('any')
@@ -10,17 +10,19 @@ license=('GPL')
depends=('git' 'python-pyqt5' 'icu' 'qt5-svg')
makedepends=('asciidoc' 'docbook-xsl' 'rsync' 'xmlto' 'python-sphinx')
optdepends=('python-pyinotify: for inotify support'
-'tk: to use the built-in ssh-askpass handler')
+ 'python-pygments: syntax highlighting'
+ 'python-pyinotify: for inotify support'
+ 'tcl: to use the built-in ssh-askpass handler')
options=('!makeflags')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/git-cola/git-cola/archive/v$pkgver.tar.gz")
-sha256sums=('9a1427b05c107ec8337881ed68bb450ac040a08880f91dcb770588f755d6fd1b')
+sha256sums=('ea482ca32fe142ddba500d2edf3a05f11e31cf193e5d7a944f3fe28c9ab123d4')
build() {
cd "$srcdir/${pkgname}-$pkgver"
- make all doc html
+ make all doc html man
}
package() {
cd "$srcdir/${pkgname}-$pkgver"
- make prefix=/usr DESTDIR="$pkgdir" install{,-doc,-html}
+ make prefix=/usr DESTDIR="$pkgdir" install{,-doc,-html,-man}
}