summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-11-09 09:00:57 -0700
committerMark Wagie2022-11-09 09:00:57 -0700
commite1320c25f3c9e2bf88ebbf397960f4a8ece5833b (patch)
tree995ff0c1943a32a63fdf9691501cb5c209786add /PKGBUILD
parent34585a89983c047c35986ada790cf96b799021ea (diff)
downloadaur-e1320c25f3c9e2bf88ebbf397960f4a8ece5833b.tar.gz
add patch for issue #1263
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4964778954f4..905f6b690d92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: TDY <tdy@gmx.com>
pkgname=git-cola
pkgver=4.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="The highly caffeinated Git GUI"
arch=('any')
url="https://git-cola.github.io"
@@ -16,11 +16,20 @@ checkdepends=('appstream-glib' 'desktop-file-utils')
optdepends=('python-pygments: syntax highlighting'
'python-send2trash: enables "Send to Trash" functionality.'
'tcl: to use the built-in ssh-askpass handler')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc})
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
+ 'https://github.com/git-cola/git-cola/commit/8f0f22e2adc7dfb09a75879fab9bb5404d33d561.patch')
sha256sums=('b5692841002895bfb2a42be5c8352dbeb454b26f267f56e15d9888e57de0a1b4'
- 'SKIP')
+ 'SKIP'
+ 'a0599494f83316bcdd5af2fd7620f10079248a0a061a009e7456579732ee46ce')
validpgpkeys=('FA41BF59C1B48E8C5F3DA61C8CE26BF4A9F606B0') # David Aguilar <davvid@gmail.com>
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # https://github.com/git-cola/git-cola/issues/1263
+ patch -Np1 -i ../8f0f22e2adc7dfb09a75879fab9bb5404d33d561.patch
+}
+
build() {
cd "$pkgname-$pkgver"
python -m build --wheel --no-isolation