summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErik Bender2022-05-18 13:07:19 +0200
committerErik Bender2022-05-18 13:07:19 +0200
commita9ddf854cbedfba62f560ddc1df5f4220a4cd50f (patch)
tree8a76074086d736b2918f68e1bd5997666643eaee /PKGBUILD
parentd07bb27e3196ae667a4f9f35dda17d1428c05ea8 (diff)
downloadaur-a9ddf854cbedfba62f560ddc1df5f4220a4cd50f.tar.gz
remove make dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd9420bcb0c0..1b7b68bf407b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@ _orga=develerik
_gourl=github.com/$_orga/$_pkgname
pkgname="${_pkgname}-git"
-pkgver=autogenerated
+pkgver=r35.76a354f
pkgrel=1
pkgdesc="Git credential.helper using 1Password for storage"
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h' 'armv6h')
url="https://$_gourl"
license=('ISC')
-makedepends=('git' 'go>=1.16' 'make')
+makedepends=('git' 'go>=1.18')
depends=('git' '1password-cli')
provides=('git-credential-1password')
conflicts=("$_pkgname-dev-git" "$_pkgname-bin" "$_pkgname")
@@ -24,11 +24,22 @@ pkgver() {
}
build() {
+ local flags
+
+ _flags=(
+ -X=$_gourl/cmd.Version="$pkgver"
+ -s
+ -w
+ -linkmode=external
+ )
+
+ export CGO_ENABLED=0
+
cd $srcdir/$_pkgname
- VERSION=$pkgver make credential-helper
+ go build -ldflags="${_flags[*]}" -o "$_pkgname" $_gourl
}
package() {
- cd ${srcdir}/${_pkgname}/bin
+ cd ${srcdir}/${_pkgname}
install -DT -m0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}