summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeoTheFox2021-08-14 00:14:55 +0300
committerNeoTheFox2021-08-14 00:14:55 +0300
commit7437bf921eb7183acb1469eb1ff75b5fd7dcfc4d (patch)
tree38c0d5380ae72074e99f86c2fcf67492571b972c /PKGBUILD
downloadaur-7437bf921eb7183acb1469eb1ff75b5fd7dcfc4d.tar.gz
inital commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf515225ae87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: NeoTheFox <aur at repraptor.33mail.com>
+
+pkgname=git-credential-keepassxc
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="git-credential-keepassxc is a Git credential helper that allows Git (and shell scripts) to get/store logins from/to KeePassXC"
+url="https://github.com/Frederick888/git-credential-keepassxc"
+makedepends=('cargo')
+arch=('i686' 'x86_64')
+license=('GPL3')
+source=("https://github.com/Frederick888/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dt "$pkgdir"/usr/bin target/release/git-credential-keepassxc
+}