summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2015-10-14 03:08:00 +0200
committerCarsten Teibes2015-10-14 03:08:00 +0200
commitae3bc5126e97ec0db505f66655f2b25a2320c5e5 (patch)
tree64801e0f071b12a7551be6378b47d243014ddeaa /PKGBUILD
downloadaur-ae3bc5126e97ec0db505f66655f2b25a2320c5e5.tar.gz
[add] git-fat-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89373751f1c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: matmoser@wu.ac.at
+
+pkgname=git-fat-git
+pkgver=r84.d5b388c
+pkgrel=1
+pkgdesc="Simple way to handle fat files without committing them to git"
+arch=('any')
+url="https://github.com/jedbrown/git-fat"
+license=('BSD')
+depends=('git' 'rsync' 'python2')
+source=("git+https://github.com/jedbrown/git-fat.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ # fix shebang
+ sed -i '1s|env python$|&2|g' ${pkgname%-*}/git-fat
+}
+
+package() {
+ cd ${pkgname%-*}
+
+ install -Dm0755 git-fat "$pkgdir"/usr/bin/git-fat
+ install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm0644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}