summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKamran Mackey2015-12-08 04:09:08 -0700
committerKamran Mackey2015-12-08 04:09:08 -0700
commit2b5d8a8581ccb58e6be7658fe009292c1d0d02fc (patch)
treebafdded9d5a0b9fac4931c98857364727e34c854 /PKGBUILD
parent37484050febff4d68d5e45d5f855a1d9fdb86954 (diff)
downloadaur-2b5d8a8581ccb58e6be7658fe009292c1d0d02fc.tar.gz
Added a git install file and systemd unit files.
Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75d4a6fadf91..9d266cc58c18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,11 @@ license=('GPL2')
depends=('git' 'asciidoc' 'gettext' 'openssl' 'expat' 'xmlto' 'curl' 'zlib' 'perl')
conflicts=('git')
provides=('git')
+install=git-git.install
source=(git://github.com/git/git.git)
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '042524f942785772d7bd52a1f02fe5ae'
+ '38c2f495f52a7afa5a0f25127050efc4')
_gitname=git
pkgver() {
@@ -41,4 +44,8 @@ build() {
package() {
cd "$_gitname"
make DESTDIR="$pkgdir" install install-doc
+
+ # git-daemon via systemd socket activation
+ install -D -m 644 "$srcdir"/git-daemon@.service "$pkgdir"/usr/lib/systemd/system/git-daemon@.service
+ install -D -m 644 "$srcdir"/git-daemon.socket "$pkgdir"/usr/lib/systemd/system/git-daemon.socket
}