summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCoelacanthus2021-03-15 18:44:15 +0800
committerCoelacanthus2021-03-15 18:44:15 +0800
commit8c67026690f22f8a0fed001398b002d8c6ba8d18 (patch)
tree6487cb5d93e1526094d5e6c25529e893454e6948 /PKGBUILD
parent5d840259c551766b498ba3605ba03a9275a9e319 (diff)
downloadaur-8c67026690f22f8a0fed001398b002d8c6ba8d18.tar.gz
upgpkg: git-grc add LICENSE and tips
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3fa67960254..afee6c0e1c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=git-grc
_pkgname=gcr
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Semantic git commits tool. use rust to rewrite the main features of git-cz."
#epoch=0
arch=('i686' 'x86_64')
@@ -15,6 +15,7 @@ depends=('gcc-libs'
)
makedepends=(cargo)
optdepends=()
+install=$pkgname.install
source=($_pkgname-$pkgver.tar.gz::https://github.com/sdttttt/$_pkgname/archive/v$pkgver.tar.gz)
b2sums=('fffc7220a9c00baffe9e489de5cf37b13a5d57d72d29ee1c8bdcc285c5ac5a1564704627a192675568c75cf8f6c390737fcba106146477c24afc5b812eb81737')
@@ -31,6 +32,8 @@ package() {
cargo install --no-track --locked --all-features --root "$pkgdir/usr/" --path .
#ln -sf "$pkgdir/usr/bin/grc" "$pkgdir/usr/bin/git-cz"
ln -sf "$pkgdir/usr/bin/grc" "$pkgdir/usr/bin/git-grc"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: