summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordasbaumwolltier2019-10-06 19:50:22 +0200
committerdasbaumwolltier2019-10-06 19:50:22 +0200
commitdf64310b25f0978a218f1e9246ac99a266f510b6 (patch)
tree8cab54e82ce206f3f2467eea52061a973b03c579 /PKGBUILD
parentf454dca3ebaf2dd2ad0748e2aa74cf962117b468 (diff)
downloadaur-df64310b25f0978a218f1e9246ac99a266f510b6.tar.gz
fixed dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03642acbdb92..89395029125b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc='Native cross platform full feature terminal based sequence editor for g
arch=('x86_64')
url='https://github.com/MitMaro/git-interactive-rebase-tool'
license=('ISC')
-depends=('git')
-makedepends=('rust' 'cargo')
+depends=('rust')
+makedepends=('git' 'rust' 'cargo')
install=$pkgname.install
sha256sums=('SKIP')
source=('git+https://github.com/MitMaro/git-interactive-rebase-tool.git')
@@ -22,8 +22,10 @@ prepare() {
build() {
cd $pkgname
- if [ $(rustup default > /dev/null 2>&1; echo $?) -ne 0 ]; then
- rustup default stable
+ if [ $(which rustup > /dev/null 2>&1; echo $?) -eq 0 ]; then
+ if [ $(rustup default > /dev/null 2>&1; echo $?) -ne 0 ]; then
+ rustup default stable
+ fi
fi
cargo build --release