summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Daudt2016-10-20 10:57:39 +0000
committerKevin Daudt2016-10-20 10:58:51 +0000
commit645d75875a11924e74045a4f159919cca89be528 (patch)
tree212d0825bfd0442e16a3111ed7755e9de2c3e9b9 /PKGBUILD
downloadaur-git-log-compact.tar.gz
initial commit
release v1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b7b6e748429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=git-log-compact
+pkgver=1.0
+pkgrel=1
+pkgdesc="compact git log --oneline with who & when"
+arch=('any')
+url="https://mackyle.github.io/git-log-compact/"
+license=('GPL2')
+depends=(perl)
+source=("https://github.com/mackyle/$pkgname/archive/v$pkgver.tar.gz")
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 git-log-compact "$pkgdir/usr/bin/git-log-compact"
+}
+
+sha256sums=('7c63e2be64588adc8843b8e280220ee41c81728b34c6fa354df3e6741e9b8c2c')