summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Gläßle2019-10-31 00:52:33 +0100
committerThomas Gläßle2019-10-31 00:52:33 +0100
commit58cc7398d41f098f269f32e91e07741e870f1ea7 (patch)
treea5c3d1576aff41826f5a0cf5677412fc8200bc30 /PKGBUILD
downloadaur-git-punchcard.tar.gz
Initial PKGBUILD, git-punchcard 2.0.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6ea4cb14d5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thomas Gläßle <aur@coldfix.de>
+
+pkgname=git-punchcard
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="Show punchcard graphs with git commit activity."
+arch=('any')
+url="https://github.com/coldfix/git-punchcard"
+license=('custom:UNLICENSE')
+depends=('git' 'python-numpy' 'python-matplotlib' 'python-pytz')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('d5905fe42a44c0c8756f6f00ece547c5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -D -m 0644 "README.rst" "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ install -D -m 0644 "UNLICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/UNLICENSE"
+}