summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAbdo Roig-Maranges2018-08-15 10:16:57 +0200
committerAbdo Roig-Maranges2018-08-15 10:16:57 +0200
commit646f9470ae4ebdad14d29e410400e5073b27beb2 (patch)
tree900b6b5a11a9f81efad7bf8c42a45a4554a46daf /PKGBUILD
parente0ac342181feed04b6608787caf5cf8f685a571f (diff)
downloadaur-646f9470ae4ebdad14d29e410400e5073b27beb2.tar.gz
use a fork again, as felipec repo is long out of date
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c78914991c7..8aec06bede24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=git-remote-hg-git
pkgver=0.3.r1.g822c6e4
pkgrel=1
-epoch=1
+epoch=2
provides=("git-remote-hg")
conflicts=("git-remote-hg")
pkgdesc="Transparent bidirectional bridge between Git and Mercurial"
@@ -12,11 +12,12 @@ url="https://github.com/felipec/git-remote-hg"
license=('GPL2')
depends=('git' 'mercurial')
makedepends=('asciidoc')
-source=("git+https://github.com/felipec/git-remote-hg.git")
+source=("git+https://github.com/mnauw/git-remote-hg.git")
md5sums=('SKIP')
pkgver() {
- git --git-dir="$srcdir/git-remote-hg/.git" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+ cd "${srcdir}/git-remote-hg"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build () {