summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2021-10-04 18:22:58 -0400
committerDaniel M. Capella2021-10-04 18:22:58 -0400
commitdc040d121687ba40ab25976cfb42ba63073284b7 (patch)
treef60448b8aab3238ad6260c9b7c233c4ed61499a8 /PKGBUILD
downloadaur-git-revise-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a27059148c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+
+pkgname=git-revise-git
+pkgdesc='Efficiently update, split, and rearrange commits'
+pkgver=0.6.0.r29.g06e9126
+pkgrel=1
+arch=('any')
+url=https://mystor.github.io/git-revise.html
+license=('MIT')
+source=("git+https://github.com/mystor/${pkgname%-git}.git")
+depends=('git' 'python')
+makedepends=('python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+b2sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname%-git}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname%-git}
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: