summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-11-17 01:53:08 +0300
committerCaleb Maclennan2021-11-17 01:53:08 +0300
commit497ca0c49a655c07a1f112afd56683b9d85a155e (patch)
treefc52e3055fbe29cb347425697794d4e9a9d3c7a2 /PKGBUILD
parent4971307770c668012b3ee0d6392e219fec5ec755 (diff)
downloadaur-497ca0c49a655c07a1f112afd56683b9d85a155e.tar.gz
upgpkg: gitahead 2.6.3-4
Overhaul build (still broken, but closer to working)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD88
1 files changed, 42 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f52e24d30d4..fc654d0fbe96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,60 @@
-# Maintainer: Tim Schumacher <timschumi@gmx.de>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Tim Schumacher <timschumi@gmx.de>
# Contributor: KillWolfVlad <github.com/KillWolfVlad>
# Contributor: WaveHack <email@wavehack.net>
# Contributor: Whovian9369 <Whovian9369@gmail.com>
# Contributor: Angelo Theodorou <encelo@gmail.com>
pkgname=gitahead
-pkgrel=3
pkgver=2.6.3
+pkgrel=4
pkgdesc='Understand your Git history!'
url='https://www.gitahead.com/'
-arch=('x86_64')
-license=('MIT')
-depends=('desktop-file-utils' 'qt5-base' 'git')
-makedepends=('cmake' 'ninja' 'git' 'qt5-tools' 'qt5-translations')
-source=(
- "git+https://github.com/gitahead/gitahead#tag=v${pkgver}"
- "gitahead.desktop"
- "gitahead.patch"
-)
-sha256sums=(
- 'SKIP'
- '254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0'
- '096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0'
-)
+arch=(x86_64)
+license=(MIT)
+depends=(desktop-file-utils
+ git
+ org.freedesktop.secrets
+ qt5-base)
+makedepends=(cmake
+ ninja
+ qt5-tools
+ qt5-translations)
+source=("git+https://github.com/$pkgname/$pkgname#tag=v$pkgver"
+ "$pkgname.desktop"
+ "$pkgname.patch")
+sha256sums=('SKIP'
+ '254b4e970a942c6ac94df177e54a6169fe7e5f5c5d0d92b6f0c0f03b7b7b2fb0'
+ '096e8f3700d7d74884e81eae3282fa1b4fad1cfa7a179ff03f1a7d89867538a0')
prepare() {
- cd "$srcdir/gitahead"
- patch --forward --strip=1 --input="../gitahead.patch"
-
- git submodule update --init --recursive
+ cd "$pkgname"
+ patch -p1 < "../gitahead.patch"
+ git submodule update --init --recursive
}
build() {
- if [ ! -d "$srcdir/gitahead-build" ]; then
- mkdir "$srcdir/gitahead-build"
- fi
- cd "$srcdir/gitahead-build"
- cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DCMAKE_PREFIX_PATH=/usr/lib ../gitahead
- ninja
+ cd "$pkgname"
+ cmake \
+ -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_PREFIX_PATH=/usr/lib \
+ -C build
+ gitahead
+ ninja -C build
}
package() {
- cd "$srcdir/gitahead-build"
-
- ninja package
-
- mkdir -p "${pkgdir}/usr/"{share,bin}
-
- cp -r "${srcdir}/gitahead-build/_CPack_Packages/Linux/STGZ/GitAhead-${pkgver}" "${pkgdir}/usr/share/gitahead"
-
- rm -rf "${pkgdir}/usr/share/gitahead/"*.so.*
- ln -s "/usr/share/gitahead/GitAhead" "${pkgdir}/usr/bin/gitahead"
-
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_16x16.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/gitahead.png"
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_32x32.png" "${pkgdir}/usr/share/icons/hicolor/32x32/apps/gitahead.png"
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_64x64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/gitahead.png"
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_128x128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/gitahead.png"
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_256x256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/gitahead.png"
- install -D -m644 "${pkgdir}/usr/share/gitahead/Resources/GitAhead.iconset/icon_512x512.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/gitahead.png"
-
- install -D -m644 ${srcdir}/gitahead/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 "${srcdir}/gitahead.desktop" "${pkgdir}/usr/share/applications/gitahead.desktop"
+ cd "$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.md
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "$pkgname.desktop"
+ ninja -C build package
+ mkdir -p "$pkgdir/usr/"{share,bin}
+ cp -r "$srcdir/build/_CPack_Packages/Linux/STGZ/GitAhead-$pkgver" "$pkgdir/usr/share/gitahead"
+ rm -rf "$pkgdir/usr/share/gitahead/"*.so.*
+ ln -s "/usr/share/gitahead/GitAhead" "$pkgdir/usr/bin/gitahead"
+ cd "$pkgdir/usr/share"
+ for s in 16x16 32x32 64x64 128x128 256x256 512x512; do
+ install -Dm0644 "gitahead/Resources/GitAhead.iconset/icon_$s.png" "icons/hicolor/$s/apps/$pkgname.png"
+ done
}