summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-05-21 10:34:27 +0200
committerhaawda2018-05-21 10:34:27 +0200
commit9e9c0ad321dd2a6d24ae84700d2688cdab82f86c (patch)
tree4b9ceb72a2a10973b36be1305a9345670f07469d /PKGBUILD
parentc01e90de50aa301d865ddf40c35877a092a4fb7f (diff)
downloadaur-9e9c0ad321dd2a6d24ae84700d2688cdab82f86c.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8aa0fcdff44b..6eb7a51c748d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,14 @@
# Contributor: WaveHack <email@wavehack.net>
# Contributor: Whovian9369 <Whovian9369@gmail.com>
-pkgname=('gitahead')
+pkgname=gitahead
pkgrel=1
-pkgver=2.1.3
-pkgdesc='THE MOST POWERFUL GIT GUI'
+pkgver=2.3.2
+pkgdesc='The most powerful git gui'
url='http://gitahead.scitools.com/'
-provides=('gitahead')
-conflicts=('gitahead')
arch=('x86_64')
license=('custom')
-depends=('')
+depends=('curl')
source=(
"gitahead-${pkgver}.bin::https://gitahead.com/downloads/v${pkgver}/GitAhead-${pkgver}.sh"
"gitahead-license"
@@ -19,14 +17,14 @@ source=(
"gitahead.png"
"gitahead.sh"
)
-sha256sums=('639eac691bcea7bc6eb19dbbe8bab188f7f9ba582a92f25b8276cbf2afdccb78'
+sha256sums=('d7f736e73e6a1e8fcf341cd6be10c622d9ebe98123cbf43375bbfeb58a41676a'
'd71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6'
'6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2'
'66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75'
'ba4e21c675ce7f49e6df27df1f29d1bb99c47679c4981657a2a4cf5d59930b4a')
prepare() {
- tail -n +224 gitahead-${pkgver}.bin > gitahead-${pkgver}.tar.gz
+ tail -n +224 gitahead-${pkgver}.bin > gitahead-${pkgver}.tar.gz # if you update, check if it is still line 224
mkdir -p gitahead-${pkgver}
bsdtar xvf gitahead-${pkgver}.tar.gz -C gitahead-${pkgver}
}