summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKillWolfVlad2017-12-15 20:50:58 +0500
committerKillWolfVlad2017-12-15 20:50:58 +0500
commite2a00961a1e9b639b3a9340d399974825ede2270 (patch)
treeab9e5143672ad89a0b73a9ec90201889bf5b28a4 /PKGBUILD
parentaa7114d9a9a0a4fe4af0bee2d60f8ace5eca7278 (diff)
downloadaur-e2a00961a1e9b639b3a9340d399974825ede2270.tar.gz
Bump to v2.0.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63e1c8b07e62..1b5bea3a2084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: KillWolfVlad <github.com/KillWolfVlad>
+# Contributor: WaveHack <email@wavehack.net>
pkgname=('gitahead')
pkgrel=1
-pkgver=1.4.12
+pkgver=2.0.0
pkgdesc='THE MOST POWERFUL GIT GUI'
url='http://gitahead.scitools.com/'
provides=('gitahead')
conflicts=('gitahead')
arch=('x86_64')
license=('custom')
-depends=('qt5-base')
+depends=('')
source=(
"gitahead-${pkgver}.bin::https://gitahead.com/downloads/v${pkgver}/GitAhead-${pkgver}.sh"
"gitahead-license"
@@ -17,11 +18,11 @@ source=(
"gitahead.png"
"gitahead.sh"
)
-sha256sums=('875b13203a990105219dcba72c8f93872f0c0f5d0f495f59c67f65608b26a3e7'
+sha256sums=('dedc8b66cdb160009c6bda86f7ca7c4e7ebe321cedffc0a2017a2f363c957e94'
'd71bfb48c954d213986816fc29478c7f80c8bd2dd10d2889bf51897d649eedd6'
'6070ebf6752f55f8b7d8a79107ce491c3acf04310eeb9a8242b83cfb4df055f2'
'66cb53fc57eb2ce2e6cd02ff392476fdfb91b723b76ef5da1856e9b5dc1b5c75'
- 'eb9f2de75d533bb1b20affe439e4bd4013511ce32829ca41e37064ef9051dd61')
+ 'ba4e21c675ce7f49e6df27df1f29d1bb99c47679c4981657a2a4cf5d59930b4a')
prepare() {
tail -n +224 gitahead-${pkgver}.bin > gitahead-${pkgver}.tar.gz
@@ -30,13 +31,13 @@ prepare() {
}
package() {
- install -d "${pkgdir}/opt/gitahead"
- cp -R "${srcdir}/gitahead-${pkgver}/Resources" "${pkgdir}/opt/gitahead"
- find "${pkgdir}/opt/gitahead/" -type f -exec chmod 644 {} \;
+ install -d "${pkgdir}/opt"
+ cp -R "${srcdir}/gitahead-${pkgver}" "${pkgdir}/opt/gitahead"
- install -D -m755 "${srcdir}/gitahead-${pkgver}/GitAhead" "${pkgdir}/opt/gitahead/GitAhead"
- install -D -m755 "${srcdir}/gitahead-${pkgver}/indexer" "${pkgdir}/opt/gitahead/indexer"
- install -D -m755 "${srcdir}/gitahead-${pkgver}/relauncher" "${pkgdir}/opt/gitahead/relauncher"
+ find "${pkgdir}/opt/gitahead/" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/gitahead/GitAhead"
+ chmod 755 "${pkgdir}/opt/gitahead/indexer"
+ chmod 755 "${pkgdir}/opt/gitahead/relauncher"
install -D -m644 "${srcdir}/gitahead-license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m755 "${srcdir}/gitahead.sh" "${pkgdir}/usr/bin/gitahead"