summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkageru2019-11-28 19:57:22 +0100
committerkageru2019-11-28 19:57:22 +0100
commit53583ba7f5de754091308f5e8ed917cc7bc608e4 (patch)
tree04bc2bd7a6b47f7631054f395016230c3a8b187a /PKGBUILD
parent787b768f812aea9c99e5d6059a998f2ad220c9cf (diff)
downloadaur-53583ba7f5de754091308f5e8ed917cc7bc608e4.tar.gz
Fix build on setups with read-only home
Patch contributed by AUR user tinywrkb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28c2a814c7af..703461300238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname='gitea'
pkgname=gitea-git
-pkgver=v1.11.0_dev_43_g05e437f8f
+pkgver=v1.11.0_dev_339_g54dab5aed
pkgrel=1
pkgdesc='Painless self-hosted Git service. Community managed fork of Gogs.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -50,10 +50,12 @@ pkgver() {
prepare() {
cd ${srcdir}/${_pkgname}
# Change default repos path for ArchLinux
- patch -Np1 -i ../../gitea-arch-defaults.patch
+ patch -Np1 -i ../gitea-arch-defaults.patch
# Fix LDFLAGS not being passed correctly
- patch -Np1 -i ../../gitea-ldflags.patch
+ patch -Np1 -i ../gitea-ldflags.patch
+ # Workaround for https://github.com/golang/go/issues/33326
+ export GOPATH="${srcdir}/gopath"
# Make sure we rebuild the mod file from Gopkg.toml to pick up any changes.
rm -f go.mod
go mod init || true